Серьезная ошибка в PHP 4.4.2

В PHP 4.4.2 была обнаружена серьёзная ошибка, приодящая к краху РНР во время попытки открыть URL, используя потоковые функции fopen. Jinx, один из лидеров команды разработчиков Joomla, в своем блоге рассказал о влиянии найденной ошибки на работоспособность Joomla.

Последствия ошибки в PHP 4.4.2 для сайтов на Joomla 1.0.x:

  • не будут работать горячие новости
  • не будут работать сторонние расширения, использующие в своем коде функции fopen, fclose, fread...

Последствия ошибки в PHP 4.4.2 для сайтов на Joomla 1.5:

  • Полностью будет неработоспособен FTP-клиент
  • не будут работать горячие новости
  • не будет работать «подгрузка» информации с «внешнего» сайта помощи.

На данный момент времени не решений этой проблемы нет. Поэтому, разработчики рекомендуют, или откатиться на PHP 4.4.1, или ждать выхода 4.4.3.

Более подробную информацию об этой ошибке можно найти на сайте разработчиков PHP.

Это интересно:

Добавить комментарий

Обновить
Защитный код

Joomla!® CMS — пожалуй, лучшая система управления контентом с открытым исходным кодом

Joomla! — это больше, чем просто программное обеспечение, это люди, включающие разработчиков, дизайнеров, системных администраторов, переводчиков, копирайтеров, и, что самое главное — простых пользователей.

Мы рады пригласить вас в ряды нашего сообщества!

Скачать Joomla! 3 Документация Joomla! CMS Свернуть

Новости портала

Новое в блогах

Видео