Joomla 4.0 будет в комплекте с Bootstrap 5

Joomla 4.0 будет в комплекте с Bootstrap 5

Свершилось чудо, в Joomla решили, что выпускать устаревший CSS фреймворк в новой версии CMS - это не есть правильно.

И уже Joomla 4.0 выйдет с Bootstrap 5 вместо Bootstrap 4. Если пропустить, всю ту воду про совместимость и огромное количество работы, которое пришлось сделать для внедрения Bootstrap 5, то я могу сказать, что это правильное решение.

А что касается совместимости разных версий Bootstrap, то отличия в них минимальны, самое главное отличие Bootstrap не требует jq, и собственно основная работа, которая была сделана, это выпиливание функций jQuery, что если честно не такая уж и огромная работа 😊

А расширения, которые уже обновились для Joomla 4, имеют либо свои стили, либо будут минимально требовать допила по внешнему виду.

https://developer.joomla.org/news/839-joomla-4-0-will-ship-with-bootstrap-5.html

id datеtime user_name message
15712282021-02-09T07:51:10+00:00Куницын ВадимAnonymous 726, Шаблоны от Joomla 3 на Joomla 4 и так работать не будут. Они имеют ряд критичных отличий. А так ни что не мешает использовать bootstrap 3 в шаблонах joomla 4. Это больше новость про админ панель joomla 4. И про базовые фреймворки, которые будут идти в комплекте.
15631872021-02-05T13:46:17+00:00Anonymous 726То есть все старые шаблоны на bootstrap 3 работать уже не будут?

Joomla!® CMS — пожалуй, лучшая система управления контентом с открытым исходным кодом

Логотип Joomla

Joomla! — это больше, чем просто программное обеспечение, это люди, включающие разработчиков, дизайнеров, системных администраторов, переводчиков, копирайтеров, и, что самое главное — простых пользователей.

Мы рады пригласить вас в ряды нашего сообщества!

Свернуть

Коротко о главном в Joomla

Новости портала

Новое в блогах

Видео

Форум о Joomla