Вышел релиз безопасности Joomla 3.6.4

Joomla 3.6.4 Stable

Вышла стабильная версия Joomla 3.6.4. Данная версия является релизом безопасности и исправляет ошибки с версии Joomla! 3.4.4 до Joomla! 3.6.3.

Скачать Joomla! 3.6.4 c GitHub

Исправления в Joomla! 3.6.4?

Безопасность

  • Высокий приоритет ядра — создание учетной записи (версии Joomla! 3.4.4-3.6.3) Подробнее »
  • Высокий приоритет ядра — повышение привелегий (версии Joomla! 3.4.4-3.6.3) Подробнее »

Исправления

  • Исправление двухфакторной аутентификации [#12497]

Полный список всех нововведений можно посмотреть в GitHub Repository. Ваши замечания и ошибки можно отправлять на Joomla! Issue Tracker.

Технические требования для Joomla 3.6

Обращаем внимание, что минимальные требования для Joomla 3.6 — версия PHP 5.3.10, рекомендуемые же версии — 5.6 или 7.0+.

Это интересно:

Комментарии  

Егор
0 # Егор 25.10.2016 18:52
Обновление вышло, но ошибка все же осталась: Error decoding JSON data: Syntax error.

Пробовал все методы, описанные на форуме:
1. update xxx_modules set params="" WHERE params LIKE '%{""}%';
2. update xxx_modules set params="" WHERE params = "{\"\"}";

Ничего не помогает.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Евгений Копылов
0 # Евгений Копылов 26.10.2016 09:54
Цитирую Егор:
Обновление вышло, но ошибка все же осталась: Error decoding JSON data: Syntax error.

Пробовал все методы, описанные на форуме:
1. update xxx_modules set params="" WHERE params LIKE '%{""}%';
2. update xxx_modules set params="" WHERE params = "{\"\"}";

Ничего не помогает.


joomlashack.com/.../...
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Сергей
+1 # Сергей 25.10.2016 19:21
жесть, че опять корявое?qv8r
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Alex
0 # Alex 25.10.2016 19:51
При обновлении - все модули отвалились, не устанавливайте
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Andre
+3 # Andre 25.10.2016 21:23
Цитирую Alex:
При обновлении - все модули отвалились, не устанавливайте

Неужели вы думаете, что разработчики не проверяют и не тестируют свои разработки?
Блин, всё прекрасно работает, и модули и всё остальное. Обновил 15 сайтов - никаких проблем.
Сначала, блин, напичкают сайт всякой левой хренью, а потом жалуются.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Георгий
0 # Георгий 25.10.2016 21:46
Вы правы. Все работает !
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Саня
0 # Саня 01.11.2016 14:44
Цитирую Andre:
Цитирую Alex:
При обновлении - все модули отвалились, не устанавливайте

Неужели вы думаете, что разработчики не проверяют и не тестируют свои разработки?
Блин, всё прекрасно работает, и модули и всё остальное. Обновил 15 сайтов - никаких проблем.
Сначала, блин, напичкают сайт всякой левой хренью, а потом жалуются.

Не умничай, сейчас разрабы не те что раньше. У меня тоже модули в админке не робят.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Вадим Куницын
+4 # Вадим Куницын 25.10.2016 22:09
Это не баг, это закешированная JS библиотека в браузере сбросьте кеш сраницы, через обновление ctrl+f5
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Анатолий.
0 # Анатолий. 04.12.2016 15:00
Точно помогло. кто бы мог подумать... :lol:
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Олег
-4 # Олег 25.10.2016 20:00
При обновлении не создаются модули.....
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Егор
0 # Егор 25.10.2016 20:02
Все модули работают исправно. Новые создаются.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Артем
0 # Артем 27.10.2016 12:45
Да есть такая проблема не один модуль не открывается белый экран и одно поле с выбором ! Исправил таким образом заходишь на ftp /media/jui/js
там есть такой фаил jquery-migrate.js и jquery-migrate.min.js просто у них меняешь имя что бы они не грузились ну или удаляешь ! и все сразу заработает ! Была проблема на вот этом сайте такая sozdanie-saytov-saratov.ru/
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Алексей
-2 # Алексей 25.10.2016 23:47
Последний запрос был отклонён, поскольку он содержит неправильный параметр безопасности (security token). Пожалуйста, обновите страницу и попробуйте ещё раз

Сайт с https не обновляется(( Кто нибудь стаокивался?
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Андрей Увиков
0 # Андрей Увиков 26.10.2016 06:56
обновил сайт с https, только по новой потом пришлось в /libraries/joomla/uri настройки прописывать
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Вадим Куницын
+1 # Вадим Куницын 26.10.2016 11:23
Логично если вы делаете хаки ядра системы.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Андрей
0 # Андрей 27.10.2016 02:09
Цитирую Андрей Увиков:
обновил сайт с https, только по новой потом пришлось в /libraries/joomla/uri настройки прописывать

а для чего Вы правите /libraries/joomla/uri?
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Борис
0 # Борис 31.10.2016 15:11
там хак для того, чтобы работал https
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Андрей
0 # Андрей 27.10.2016 02:08
Несколько сайтов на https, при обновлении ни каких проблем не заметил.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Владимир Федоров
0 # Владимир Федоров 26.10.2016 04:16
Обновился с 3.5.1 на 3.6.4 (4 сайта) – полет нормальный, модули и прочее работают.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Артем
0 # Артем 27.10.2016 12:44
Да есть такая проблема не один модуль не открывается белый экран и одно поле с выбором ! Исправил таким образом заходишь на ftp /media/jui/js
там есть такой фаил jquery-migrate.js и jquery-migrate.min.js просто у них меняешь имя что бы они не грузились ну или удаляешь ! и все сразу заработает !
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
GorYa
0 # GorYa 26.10.2016 12:39
У меня в последних двух версиях проблема лишь с обновлением напрямую. Приходится скачивать файл апдейта и устанавливать вручную
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Вадим Куницын
0 # Вадим Куницын 26.10.2016 19:41
Есть вероятность, что вы не обновили компонент обновления Joomla и из-за этого у вас проблемы с обновлением по кнопке.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
GorYa
0 # GorYa 27.10.2016 08:18
Цитирую Вадим Куницын:
Есть вероятность, что вы не обновили компонент обновления Joomla и из-за этого у вас проблемы с обновлением по кнопке.


Сейчас стоит компонент обновления 3.6.2 и вроде бы это последний.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Борис
0 # Борис 31.10.2016 15:10
Здравствуйте.

С 3.4.Х до 3.6.4 можно обновляться только через 3.5.х?
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Олег
0 # Олег 31.10.2016 21:18
Пробовал несколько раз обновиться с 3.4.8 до 3.6.4 на сайте белая страница, ошибка 500. Админка работает.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Сергей
0 # Сергей 01.11.2016 05:01
Обновился, пока все в норме!
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Ivan Ershov
0 # Ivan Ershov 08.11.2016 20:00
А что стало с рендерами, ну например head.php из librares/joomla/document/ html/renderer/head.php есть но какой то он стал не такой как раньше:)
А то я там дополнительные тэги прописывал...или я смотрю не туда куда-то...
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Дмитрий Рекун
0 # Дмитрий Рекун 09.11.2016 13:08
Цитирую Ivan Ershov:
А что стало с рендерами, ну например head.php из librares/joomla/document/html/renderer/head.php есть но какой то он стал не такой как раньше:)
А то я там дополнительные тэги прописывал...или я смотрю не туда куда-то...

Они теперь в /libraries/joomla/documen t/renderer
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Олег
0 # Олег 14.11.2016 19:32
ни кто не сталкивался? после обновления, с формы обратной связи не доходят письма (с джумлы тестовые приходят), в чем может быть проблема
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Андрей
0 # Андрей 13.12.2016 22:58
аналогичная ситуация, тестовые с админки приходят, с формы обратной связи выдает страницу " Неверный параметр"
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Алина
0 # Алина 14.11.2016 21:22
После обновления с Joomla 3.6.2 на 3.6.4 перестала работать главная страница.
Админка и внутренние работают.
Ошибка: Fatal error: Call to a member function countItemComments() on a non-object in /var/www/.../modules/mod_ k2_content/helper.php on line 376
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Вадим Куницын
0 # Вадим Куницын 15.11.2016 15:52
Отключить модуль и разбираться почему он так вызывает функцию.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Alex
0 # Alex 19.11.2016 19:05
Открыл админку в другом браузере – модули не исчезают, и не сворачиваются.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Андрей Озеров
0 # Андрей Озеров 24.11.2016 22:01
После обновления с 3.6.2 до 3.6.4 в настройках модулей появилась ошибка "Произошла ошибка при получении данных JSON: код состояния HTTP 404." При этом все работает корректно, сохраняет/закрывает, но что ни делал, ошибка никуда не уходит. Что делал:
- чистил кэш ctr+F5/ открывал в другом браузере
- менял версию php на хостинге
- удалял/возвращал файл core.js
- менял/возвращал шаблон админки

что еще посоветуете? :-)
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Вадим Куницын
0 # Вадим Куницын 25.11.2016 17:02
не совсем типично но вероятно проблема в этом joomlaportal.ru/.../...
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Андрей
0 # Андрей 01.12.2016 17:56
Цитирую Андрей Озеров:
После обновления с 3.6.2 до 3.6.4 в настройках модулей появилась ошибка "Произошла ошибка при получении данных JSON: код состояния HTTP 404." При этом все работает корректно, сохраняет/закрывает, но что ни делал, ошибка никуда не уходит. Что делал:
- чистил кэш ctr+F5/ открывал в другом браузере
- менял версию php на хостинге
- удалял/возвращал файл core.js
- менял/возвращал шаблон админки

что еще посоветуете? :-)


Аналогичная проблема. Кто-нибудь подскажет, как решить?
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Андрей
0 # Андрей 01.12.2016 17:59
НАШЕЕЕЕЕЕЕЕЕЕЕЕЛ! Проблема была в AdvancedModuleManagerPro. Была установлена старая версия 5.3.6.
Сейчас поставил версию 6.2.7 - и надпись исчезла!
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору

Добавить комментарий

Обновить
Защитный код

Joomla!® CMS — пожалуй, лучшая система управления контентом с открытым исходным кодом

Joomla! — это больше, чем просто программное обеспечение, это люди, включающие разработчиков, дизайнеров, системных администраторов, переводчиков, копирайтеров, и, что самое главное — простых пользователей.

Мы рады пригласить вас в ряды нашего сообщества!

Скачать Joomla! 3 Документация Joomla! CMS Свернуть

Новости портала

Новое в блогах

Видео