Релиз безопасности Joomla 3.7.1

Joomla 3.7.1

Вышла стабильная версия Joomla! 3.7.1. Данная версия является релизом безопасности и исправляет ошибки в версии Joomla! 3.7.0.

Скачать Joomla! 3.7.1 c GitHub

Исправления в Joomla! 3.7.1?

Безопасность

  • Низкий приоритет ядра — SQL-инъекция (версии Joomla! 3.7.0) Подробнее »

Исправления

  • Исправления в новом календаре #15573
  • Инъекция зависимости JInput в обработчике сессий #15605
  • Исправления в JMenuItem #15553
  • Исправления сортировки статей в административной части сайта #15655
  • Исправлена обработка миллисекунд для версий PHP ниже 7.1.0 #15853
  • Исправление JFilterInput #15966
  • Исправлен редирект для расширений, которые используют старую версию FOF2 #15738
  • Исправлено удаление пустого файла заблокированного кэша, если функция обратного вызова завершает процесс #15592

Полный список всех исправлений можно посмотреть в GitHub Repository. Ваши замечания и ошибки можно отправлять на Joomla! Issue Tracker.

Что нового в ветке Joomla 3.7?

  • Кастомных поля — 15 типов полей для ваших статей, пользователей и контактов. 
  • Компонент ассоциаций многоязычности — упросит ведение и создание сайтов на нескольких языках.
  • Менеджер меню административной панели.
  • Обновление базового редактора Joomla - TinyMCE — больше кнопок и больше возможностей. Можно добавлять ссылки на статьи, контакты, разделять кнопки редактора по группам доступа пользователей.
  • Блокировка удаления компонентов — можно заблокировать удаление некоторых компонентов Joomla, что позволит избежать проблем с обслуживанием сайта.
  • Создание материала и пункта меню в один шаг.
  • Общая авторизация — административная и фронтальная части сайта.
  • Новый календарь для даты и времени.
  • Расширен вывод параметров при редактировании статьи.

Это интересно:

Комментарии  

Маргарита
+1 # Маргарита 18.05.2017 12:45
Моя ошибка, связанная с переключением языков на многоязычном сайте, исчезла после обновления на версию Joomla 3.7.1. Ура!
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Валентин
0 # Валентин 18.05.2017 22:40
Не смог обновиться с 3.6.5 до 3.7.1, пишет ошибку:
ERROR
Invalid login

Подскажите в чем причина?
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Валентин
0 # Валентин 21.05.2017 12:26
Решение проблемы найдено!
Оказывается это виноват браузер Google Chrome.
Через Opera обновился без проблем.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Алексей
0 # Алексей 22.05.2017 09:46
Не могу найти и отключить - видимо убрали - плагин проверки версии php и вывода ошибки на главную админки в случае версии php ниже 5.6. Достали если честно. Вначале ввели эту раздражалку, сейчас и выключить ее возможность убрали :sad:
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору
Ирина
-1 # Ирина 22.05.2017 16:10
Только что обновилась с 3.7 на 3.7.1, невозможно зайти ни в один модуль HTTP ERROR 500, 5 минут назад все работало. Очистка КЭШа не помогла.
Ответить | Ответить с цитатой | Цитировать | Сообщить модератору

Добавить комментарий

Обновить
Защитный код

Joomla!® CMS — пожалуй, лучшая система управления контентом с открытым исходным кодом

Joomla! — это больше, чем просто программное обеспечение, это люди, включающие разработчиков, дизайнеров, системных администраторов, переводчиков, копирайтеров, и, что самое главное — простых пользователей.

Мы рады пригласить вас в ряды нашего сообщества!

Скачать Joomla! 3 Документация Joomla! CMS Свернуть

Новости портала

Новое в блогах

Видео